Help:Download

From Mapping on MediaWiki
Jump to: navigation, search

Admin manual

Download

Installation

Configuration

Troubleshooting

User manual

On this page you can download the mapping extensions you might need. See their individual pages for their specific functionality in order to determine which ones you need.

Maps

Maps 1.0.5 dependencies
Name Required Recommended Version Supported Versions
MediaWiki Yes 1.18 or above 1.17 or above
Validator Yes 0.4.13 0.4.x later then 0.4.10
Crystal Clear action build.png Download Maps

For a complete list of downloads, including obsolete and experimental releases, go to the Google code download page. If you have MediaWiki 1.17 or above, simply get the latest version. If you are using MediaWiki 1.15.x or 1.16.x, get the latest 0.7.x release.

Subversion downloads

You can also download the code directly via SVN from the MediaWiki source code repository, at http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/Maps/REL_1_0_5. From a command line, you can call the following:

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/Maps/REL_1_0_5

To get the latest changes, you can download the code directly from the trunk. Note that trunk requires MediaWiki 1.17 or above.

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/trunk/extensions/Maps

For MediaWiki 1.15.x and 1.16.x installs, you can get the latest Maps 0.7.x code from this branch:

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/branches/Maps0.7.x

Note that this is discouraged when stability is a big concern.

To update a branch, use:

svn switch http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/Maps/REL_1_0_5

Package downloads

Compatibility and dependencies

You can see the dependencies of the current release in the box on the right. For a full list of dependency tables of all releases, see the Maps dependencies category.

Semantic Maps

Semantic Maps 1.0.5 dependencies
Name Required Recommended Version Supported Versions
MediaWiki Yes 1.18 or above 1.17 or above
Maps Yes 1.0.5 1.0.5, 1.0.4, 1.0.3, 1.0.2
Validator Yes 0.4.13 0.4.x later then 0.4.10
Semantic MediaWiki Yes 1.7 1.7 or above
Semantic Forms No 2.3 or above 1.9 or above, possibly older ones
Crystal Clear action build.png Download Semantic Maps

For a complete list of downloads, including obsolete and experimental releases, go to the Google code download page. If you have MediaWiki 1.17 or above, simply get the latest version. If you are using MediaWiki 1.15.x or 1.16.x, get the latest 0.7.x release.

Subversion downloads

You can also download the code directly via SVN from the MediaWiki source code repository, at http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/SemanticMaps/REL_1_0_5. From a command line, you can call the following:

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/SemanticMaps/REL_1_0_5

To get the latest changes, you can download the code directly from the trunk. Note that trunk requires MediaWiki 1.17 or above.

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/trunk/extensions/SemanticMaps

For MediaWiki 1.15.x and 1.16.x installs, you can get the latest Maps 0.7.x code from this branch:

svn checkout http://svn.wikimedia.org/svnroot/mediawiki/branches/SemanticMaps0.7.x

Note that this is discouraged when stability is a big concern.

To update a branch, use:

svn switch http://svn.wikimedia.org/svnroot/mediawiki/tags/extensions/SemanticMaps/REL_1_0_5

Package downloads

Compatibility and dependencies

Notice: Semantic Maps and Maps are always released together. This means you should always use the same version of Maps as the one of Semantic Maps you have. For example Maps 0.3.4 and Semantic Maps 0.3.4, but not Maps 0.2 and Semantic Maps 0.3.

For a full list of dependency tables of all releases, see the Semantic Maps dependencies category.