Maps and Semantic Maps 0.7.6 released

From Mapping on MediaWiki
Jump to: navigation, search

March 21, 2011

Maps 0.7.6 and Semantic Maps 0.7.6 are now available for download.

What's new?

Mainly bugfixes in both extensions, but also better support for the mapping specific parameter in the Special:Ask GUI of SMW.

What's next?

Maps and Semantic 0.8, the next big version of both extensions, is mostly done, and is now on svn trunk (the 0.7.x extensions are now on their own branches). This version includes a complete rewrite of all the mapping javascript, simplification of parameter handling and some very nice new features. These include full Google Maps v3 support, geocoding via the new GeoNames API, improvements to the map form inputs, and more. As of 0.8, the mapping extensions will require MediaWiki 1.17 or above, as the MediaWiki resource loader, which was introduced in 1.17, is used. This means the 0.7.x branch will continue to be supported for a while (which will mainly be bugfixes and minor tweaks), and will continue to be used in the Semantic Bundle for now. The actual 0.8 release can be expected a few weeks after MW 1.17 finally gets released.